Suse Linux SLES 10 SP 3 Oracle problems with missing compat libstdc++ package

If you are trying to install Oracle database product(s) on Suse Novell Linux 10 SP 3 you may experience problem with missing compat rpm package. Novell SLES actually provides all the necessary files via libstdc++33 howerver Oracle installation doesn’t really recognize it and reports missing compat libstdc++ package.

If you have installed you may remove the following packages running the following rpm command:

rpm -e libstdc++33
rpm -e libstdc++33-32bit

A good alternative is to find a compat libstdc++ package from SLES 10 SP 2 and it works perfectly. The compact-libstdc++ package you need is as follows:

compat-libstdc++-5.0.7-22.2.x86_64.rpm

Download it and install it running:

rpm -ivh compat-libstdc++-5.0.7-22.2.x86_64.rpm


Comments

  1. jin says:

    compat-libstdc++-5.0.7-i586.rpm

  2. Kai Root says:

    Excellent blog here! Additionally your web site a lot up very fast! What host are you using? Can I get your associate link for your host? I desire my website loaded up as quickly as yours lol

  3. Tech Guy says:

    It’s not only the host, it’s also caching and optimization. Interested in WordPress tunning? You may want to bug Linuxadmin guys

Leave a Reply